Mar 27, 2015

Howto: Fix "Gem::InstallError: metasploit_data_models requires Ruby version >= 2.1" in Metasploit

If you found error "Gem::InstallError: metasploit_data_models requires Ruby version >= 2.1", try to change your ruby to version >=2.1.0

if you use rvm
(#source /usr/local/rvm/scripts/rvm)
# rvm use ruby-2.2.0

if you use ubuntu
# update-alternatives --config ruby

Mar 25, 2015

Tools: Commix - Automated All-in-One OS Command Injection and Exploitation Tool

Commix (short for [com]mand [i]njection e[x]ploiter) has a simple environment and it can be used, from web developers, penetration testers or even security researchers to test web applications with the view to find bugs, errors or vulnerabilities related to command injection attacks. By using this tool, it is very easy to find and exploit a command injection vulnerability in a certain vulnerable parameter or string. Commix is written in Python programming language.

Source:: https://github.com/stasinopoulos/commix

Mar 24, 2015

Solaris Auditd Log Class

0x00000001:fr:file read
0x00000002:fw:file write
0x00000008:fm:file attribute modify
0x00000010:fc:file create
0x00000020:fd:file delete
0x00000080:pc:process
0x00000800:ad:administrative
0x00001000:lo:login or logout
0x40000000:ex:exec
0xffffffff:all:all classes   

Source:: http://www.deer-run.com/~hal/sysadmin/SolarisBSMAuditing.html

Mar 23, 2015

Howto: Install and use ssllabs-scan on Ubuntu

1. Install GO Language
# apt-get install golang

2. Download ssllab-scan
# git clone https://github.com/ssllabs/ssllabs-scan

3. Run with
# go run ssllabs-scan.go <Target>

Example::
# go run ssl-labs-scan.go https://www.gmail.com

 



If you like my blog, Please Donate Me
Or Click The Banner For Support Me.